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Exercise 04    Name: _________________________ 
DIVA-GIS: Distribution and Diversity of Wild Potatoes 

(Heavily modified from www.diva-gis.org by C.R. Hardy, Feb 2009) 
 

This plus a WORD document is to be done as homework for 10 pts. Due Feb 23, 2009 at the 
beginning of class. 

 
You should have gone through the tutorial and at least glanced through the 
manual before starting this exercise.  

Wild potatoes (family Solanaceae; genus Solanum section Petota) are relatives of the 
cultivated potato. There are nearly 200 different species that occur in the Americas. 
Their geographic distribution was recently described by Hijmans and Spooner 
(Hijmans, R.J., and D.M. Spooner, 2001. Geographic distribution of wild potato 
species. American Journal of Botany 88: 2101-2112). In this exercise, we analyze 
some of the same data that were used in this paper.  

NOTE: If at any time DIVA-GIS appears unresponsive during this exercise, make sure 
your project is saved (as a .div file), close DIVA-GIS and then reopen it and your file to 
pick up where you left off.  
 
A. Grab the potato data from the course website 
(http://herbarium.millersville.edu/471.php). 

 Unzip the zipped folder “potato-exercise-data” and load it onto your flash 
 drive or the desktop of your computer.  

  
B. Open DIVA-GIS and Build a Map of the Americas 

 Layer > Add Layer to add the ‘pt_countries.shp’ shapefile to the map. This 
shapefile contains the administrative boundaries for American countries.  

 

C. Import specimen data  

1) Open MS Excel and open the file ‘wildpot.txt’ from the “potato-exercise-data” 
folder.  The file is a tab-delimited txt (.txt) file.  

 Convert the DMS (degree, minute, seconds) coordinates to decimal degrees 
using the appropriate formulaic mathematical expression into two new columns 
in Excel (one for Longitude, the other for Latitude). [See Chapter 2 of the 
DIVA-GIS manual or your lecture notes.] 
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Pay attention to the heading (N vs. S, E vs. W) as these will determine the sign (- 
or +) for the decimal degrees.   

 Format the new latitude and longitude columns to represent the numbers to 5 
decimal places (5 decimal places translates to an accuracy of less than 1 m at 
our latitude; 4 places to less than 10 m).   

 Save the file in tab delimited text format (as “wildpot-decimaled.txt”). Make 
sure that you do not lose the decimal numbers of the coordinates as you save 
the file.  

 
 
 

2) Having saved the file, close Excel (you cannot open your new file in DIVA-GIS 
until you close it in Excel).  

 
3) Import wildpot-decimaled.txt to points (i.e., make it a shapefile) and name 

the shapefile “wild potatoes”, save it in your folder. The shapefile will 
automatically be added to you map as the top layer.  

 
4) Are there any specimens that appear to be positioned oddly in the an ocean?  
 
 If so, how many? ______________________ 
 
 Do you think this is in error?__________________ 
 
 Retrieve (view) the data associated with such a point to determine whether 

or not its position seems appropriate using the information (i) tool as follows:  
 

 With the new specimen layer “wild potatoes” active (selected), click the 
information (i) tool from the tool bar at the top of the default data view 
window (see below). Click on that “outlier” point.  

    
 
 

 Which island was this specimen collected on? _____________________
   

If you get this Alert Box, click 
“yes”.  
 
This Alert appears when you 
attempt to save your data to a 
.txt file rather than an Excel 
(.xls) file. Text files cannot 
carry any fancy Excel 
formatting such as column 
margins, colors, etc. That is 
just fine. 
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5) Prepare a figure of this plot of specimens—i.e., a “distribution map” for 

Solanum sect. Petota.   
 
 In DESIGN view (lower right tab of program window), click “OK” to show the 

map you just created.  Add a scale bar and a North directional from the tool 
bar (see below).   

 
  
 Then copy this image to the clipboard and paste it into a WORD document. 

Label this figure “Figure 1” along with a descriptive caption at the bottom of 
the figure. Save your WORD document as “wildpot-YOURNAME.doc”.  

 
B. Determine which country has more species.  

1) Switch from DESIGN view back to DATA view.  

2) Summarize the data by country as follows:  

 Make the “wild potato” shapefile layer the active layer/file and click on 
Analysis > Point to Polygon (see figure below). Select ‘species’ as the field of 
interest. Add the shapefile of countries (“pt_countries.shp”) in the ‘define 
shape of polygon’ box.  

 

 Select an output filename (call it “species-by-country”) and press Apply. Be 
patient while the computer generates a new layer that color codes the 
countries according to the number of wild potato species they have.  
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3) Make this new layer visible and the other two layers invisible. Double click on the 
new layer and change its legend attributes.  

First, on the single tab, double click on the symbol and change its style to ‘solid fill’ if 
is not already. Then go to the classes tab, select the “SPP” field, 6 classes, and reset 
the legend. SPP stands for the number of distinct species. See figure below. Don’t 
worry about the other fields (however, the manual will give you this information).  

Manually change the values (and colors) of the different classes to get something like 
this below, where countries with no potato species are white, those with 1<10 are 
yellow, those with 10<20 are green, 20<30 are blue, 30<40 are purple, and >=40 are 
red.  

 

 

Which country has the most species and with how many? ________________ 

Which country is second and with how many? ___________________ 

Which country is third and with how many? ___________________ 

Fourth? ___________________ 

Fifth? ___________________ 
 
Sixth? ___________________ 
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Move the shapefile of wild potato collections to the top and make it visible if not 
already.  
 
In DESIGN view, add legend (to explain the color coding), add a scale bar, and add a 
North directional to the map.  
  
 Copy to the computer clipboard and paste it into your existing WORD document 
 as Figure 2, along with a descriptive figure caption.  
 
4) Back in DATA view, open the table associated with the shapefile, you will see 

that there are records for many countries that have no potatoes at all. To 
simplify our table, we first select the records with more than 0 observations 
(OBS). Using Layer > Select Records and the select by query tab (see below). 
Add your query and click Apply.  

 

After entering the appropriate query all countries with potatoes will be colored 
yellow on the map (they are ‘selected’). Now save the selection to a new shapefile 
as “countries-with-wildpotatoes” in your personal potato data folder (“DATA > 
Selection to new shapefile”): it should be added to the map automatically. If not, 
then add it using the LAYER > Add layer function.  

  
 Make the species-by-countries layer active and unselect the countries using 
 LAYER > Clear selection.  
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Make the new “countries-with-wildpotatoes” layer the active layer and open the 
table of data associated with it. The table should look something like this:  

 

The information by country is of interest and can be useful. However, it is not very 
helpful for understanding the spatial distribution of wild potatoes or for guiding 
collection efforts because the countries have such different sizes and shapes, and 
because most are very large and it does tell us where in one particular country we 
expect to find many or few species. It is in most cases better to use grids with cells of 
equal area, and that is what we will do next.  

 

5) Save the project to your personal potato data folder as ‘YOURNAME-
Solanum.div’.  

C. Prep for producing a species richness grid: Project the data  

To be able to use a grid with cells of equal area, the data needs to be projected. 
If the lat/long data were used, cells of say 1 square degree would get smaller as 
you move away from the equator: think of the meridians (vertical lines) on the 
globe getting closer to each other as you go towards the poles.  

For small areas, the standard UTM (Universal Transverse Mercator coordinate 
system) would be a good projection, but in this case we will use a projection that 
can be used for a complete hemisphere: the Lambert Equal Area Azimuthal 
projection. Before you project your data, you must choose a map origin for your 
data. This should be somewhere in the center of your points, to minimize the 
distance (and hence distortion) from any point to the origin. In this case, the 
center could be (-80, 0). Confirm for yourself that these coordinates are roughly 
in the middle of your collections by running the mouse over the map image and 
reading the “live” coordinates in the bottom left of the program window until 
your approach 80 degrees west and 0 degrees (the equator).  
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1) Right click on each layer in the layers palette to remove all layers from the map 
except the wild potato and the original country shapefile.  

 
2) Project these files using Tools > Projection.  
 Choose “projection of hemisphere”, then the “Lambert Equal Area Azimuthal 
 (equatorial)” projection.  

 
On the custom tab, change the central meridian to -80. Using the “OUTPUT” 
button, browse to your personal folder and save the files with filenames such as 
‘wild potatoes lambert’ and ‘countries lambert’. Press Apply. Be patient…  

 

 

3) Make all layers visible.  

 

4) Zoom to the maximum extent (right click on data-map window, then “full 
extent), you see the projected data. Note that the shape of the countries is 
much more similar to their shape on a globe than before projecting. In the 
bottom left corner you can see that the coordinate system has changed. You 
likely see very large numbers now: these express the distance from the origin 
(-80,0 degrees) in meters rather than in degrees. If you make the projected 
potato file invisible, you will see that the unprojected data is still present on 
the map, near the origin of the projected data. Zoom in to that area with a 
click-and-drag of the Magnifying Glass tool from the toolbar.  

Clearly one cannot combine projected and unprojected data (or data in  
two different projections) on a single map. Get rid of the old, unprojected 
data.  
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5) Now go to Map>Properties and change the projection to “Other” and the units 
to ‘meters’. This will allow for displaying a correct scale on the map.  

6) Save the project to ‘YOURNAME-Solanum’.   

D. Species Richness on a grid  

1) Let’s determine the distribution of species richness (i.e., species per unit area) 
using a grid. This can be done using the point-to-polygon option that we used 
before, but in most cases it is more appropriate to use Analysis>Point to grid.  

 
 
From the Main tab, select ‘Richness’ and ‘Number of different classes 
(Richness)’.  
From the Parameters tab,  and select the ‘Species’ Field.  
 
 
Create a new grid: In the Options window, set the X and Y dimensions of the 
cell size to 100,000 (as the projection is in meters this means that the cells will 
be 100 by 100 km). Use the default option (‘simple’) for the Point-to-grid 
procedure.  

Choose an output filename and save it as ‘species richness’ in your personal 
potato data folder, press Apply. Play around with the cell size (try 100 by 100 
meters, 10,000 by 10,000, etc.). Return to 100,000 by 100,000.  

The Analysis>Point to grid box. 
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2) Prepare this richness map as a figure in your growing WORD document. 
 
 2a. Slide this new “species richness” layer to the top of the layers palette.  
 You’ll note that the country borders are obscured by the grid cell colors.  

 

 2b. Double click on the grid layer on the layers palette to alter its properties.  

 2c. In the properties window, remove the first row that reports grid cells with 0 
 species as white. This “white” is masking most of the country borders.  

 Also check the box in the lower left to make those grid cells with no data 
 transparent.  

 2d. Click Apply.  

  2e. Now the map looks better and we can switch to DESIGN view to make a 
 map image for pasting into our WORD document. MAKE SURE THE RICHNESS 
 GRID IS THE TOP LAYER BEFORE SWITCHING TO DESIGN VIEW. 

  Add a scale bar, North directional arrow, and the legend (showing the  
  richness color scale only) to the map.   

  Copy to the clip board and paste it into your WORD document as Figure  
  3. Give this figure a descriptive caption.  

 Here briefly contrast the information content and meaning of the report of 
 species by country vs. by grid cell.  
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Which map, species-by-country or species-by-grid would be more useful for targeting 
fieldwork meant to locate as many species of wild potato as efficiently as possible? 
Explain.  

              

              

              

 

Which map would be more useful for identify richness “hotspots” for wild potato 
species? Why? 

              

              

              

 

 
Give me this document with your answers marked onto 
it. Also email the entire WORD file with the three 
figures to me. (10 pts.). 


